WordPress Ending IE Support for 10 and Below

It has finally come time to put that old Internet Explorer into the home for retired software. WordPress posted this blog entry a couple of days ago – https://wptavern.com/wordpress-4-8-will-end-support-for-internet-explorer-versions-8-9-and-10, and it is worth taking a read.

Internet Explorer is strictly “Old School” and is not up to modern standards. It has a number of weaknesses, but there’s no good reason to has that out here. I will mention, however, that one of the most important reasons has to do with security. In short, it stinks.

There’s any number of good browsers out there, including Edge, Firefox, Chrome, and Opera. If you are still using IE, it is time to get a new one.